Page 2 of 2 FirstFirst 12
Results 16 to 20 of 20
  1. #16

    Join Date
    Jun 2018
    Location
    San Francisco Bay Area
    Posts
    8
    Post Thanks / Like

    Re: What did I do wrong?

    Thank you everyone for the input. My plan was to do a couple passes of D302 on a MF finishing pad to make sure any residual Jetseal didn`t interfere with soaking the spots. Turns out soaking was unnecessary, the spots were half gone. After another 4 or 5 passes the bumper looked clean again! So I finished up with a coat of Jetseal and then put a coat of Pete`s `53 wax on top of that. I need to apply a new coat of wax to the rest of the car, anyways, but I`ll get to that this weekend. I really, really appreciate all the help, this is an awesome community!

    Since it`s a black car, and my daily driver, I am starting to see tiny spiderweb scratches. For future polishing my thinking is that I would start with Menzerna 3500 on a white polishing pad (or equivalent if I`m not using hex logic pads) and if that doesn`t take care of things I`ll try Optimum Hyper Polish and an orange pad or a MF finishing pad. Does that seem like a reasonable approach?

    Again, thanks for all your help!

    Likes SWETM liked this post

  2. #17
    rlmccarty2000's Avatar
    Join Date
    Dec 2014
    Posts
    3,493
    Post Thanks / Like

    Re: What did I do wrong?

    BMW paint is on the hard side. I would try the Menz 3500 on the microfiber finishing pad and see if you like the results. Glad everything worked out.

  3. #18

    Join Date
    Jun 2018
    Location
    San Francisco Bay Area
    Posts
    8
    Post Thanks / Like

    Re: What did I do wrong?

    Quote Originally Posted by rlmccarty2000 View Post
    BMW paint is on the hard side. I would try the Menz 3500 on the microfiber finishing pad and see if you like the results. Glad everything worked out.
    I haven’t done much with diminishing polishes on microfiber, with Menz would I prime the pad with polish or would I use a squeeze of detail spray to prime and 4 or so drops of polish?

  4. #19
    rlmccarty2000's Avatar
    Join Date
    Dec 2014
    Posts
    3,493
    Post Thanks / Like

    Re: What did I do wrong?

    Quote Originally Posted by rhavyn View Post
    I haven’t done much with diminishing polishes on microfiber, with Menz would I prime the pad with polish or would I use a squeeze of detail spray to prime and 4 or so drops of polish?
    It’s personal preference, but for microfiber pads I prime the whole pad with polish. On foam I use a few drops of polish.
    Likes BudgetPlan1 liked this post

  5. #20

    Join Date
    Sep 2002
    Location
    NE Ohio
    Posts
    81,891
    Post Thanks / Like

    Re: What did I do wrong?

    I sure hope it is just water/etc. spots and not cc failure, but I`m a bit perplexed why somebody would still note that it looks like that under certain lighting conditions. IME most of the time something`s "only visible under certain lighting conditions" that simply means that the lighting isn`t right for inspection most of the time (and *IS* right when the problem is apparent).
    Likes Stokdgs liked this post

 

 
Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 16
    Last Post: 12-19-2009, 11:55 AM
  2. what am i doing wrong
    By Nebraskaz71 in forum Machine Polishing & Sanding
    Replies: 13
    Last Post: 03-27-2006, 12:32 AM
  3. hmm, what went wrong??
    By scottabir in forum Car Detailing
    Replies: 7
    Last Post: 11-16-2003, 07:32 PM
  4. What did I do wrong?
    By PerfectionDetailing in forum Car Detailing
    Replies: 6
    Last Post: 09-21-2003, 11:05 PM
  5. HELP, what did I do wrong?
    By ClayBartrug in forum Car Detailing
    Replies: 2
    Last Post: 06-05-2002, 10:21 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •