Page 1 of 3 123 LastLast
Results 1 to 15 of 31
  1. #1

    Join Date
    Feb 2014
    Location
    Rochester Ma
    Posts
    1,204
    Post Thanks / Like

    Very Displeased with Ibrid

    So let me start this off by saying I am waiting for a call back from a tech supervisor but I still want to share my displeasure with this tool.

    Back in November of 2016 I purchased the new short neck kit. I used it a little bit during November when I was in Florida detailing. After that it pretty much sat the next 4 months during winter. At the end of April I was in the middle of a job and the power started cutting in and out. So I placed a call to Rupes and they were very pleasant to deal with and offered to send me a label to send it in under warranty. They got the tool about 7 days +/- and sent me notification on May 2 stating they were sending me a new one at no charge. One of two of the connection points was loose and causing the issue.

    Fast forward to today. I have had the new warrantied unit since beginning of May. So 4 months of actual use and guess what. Same thing starts happening. Now I will say that up until today I have been using it mainly with the batteries with no issues. Today I was using it with the AC power supply. Today I have a 63 VW bug that is a very important job and the Ibrid really comes in handy for this vehicle and now I won`t be able to complete some of the intricate polishing. I thought maybe my power supply is bad or acting up so I unplug it and switch back to batteries and still the same issues. My honest thought is that the power supply is too big and heavy for the little prongs inside and if you bump it the weight causes the prongs to come loose. Just my thought.

    Either way I am not very happy at all as I have a 650$ tool that has gone down 2 times since April that I cannot depend on at all now. IF they warranty it again at this point I will be probably selling it and going back to a Flex PE8.

    I`m sure all the Rupes faithful will come in and chew me out but hey I am speaking truth here. The first time it happened I chalked it up to just bad luck. Now it`s unacceptable.

    Most who know me know I wouldn`t go a post something like this at all but just do some research before you go and drop 650$

    Sorry for the rant everyone.
    IGL Authorized Coating/Kenzo Installer

    Final Inspection Auto detailing- https://www.facebook.com/FinalInspection?_rdr=p
    Likes ShakingHorizons, trashmanssd liked this post
    Thanks trashmanssd thanked for this post

  2. #2
    Wax Waster Ronkh's Avatar
    Join Date
    Mar 2008
    Location
    SwFL
    Posts
    25,836
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    If you need, I can lend you my long neck (still haven`t used it)
    Formerly the "Best Detailer", now just Super Wax Waster Man. Not necessarily tactful, but normally right. It`s good to be da King !!!
    Likes GearHead_1 liked this post

  3. #3

    Join Date
    Sep 2002
    Posts
    79,528
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    Justins00ss- I appreciate your posting that, and will be interested to hear if others have had this problem. I`m seriously considering one (well, two now that they can be purchased w/o getting the full kit) and/but I sure don`t want an(other) expensive paperweight. Tools that don`t do the job, for whatever reason, bug me.

  4. #4
    512detail's Avatar
    Join Date
    May 2013
    Location
    Kyle, Tx
    Posts
    8,069
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    wow Justin sorry you are having that issue

    I have the long neck from when they first came out and luckily I have had no issues. I`ve never even used it with the cord attachment

    the only issue I have with my nano is that it doesn`t cut the same throughout the life of the battery, there is a little more power through the first half of the battery

    I guess mine is now out of warranty so I would be in a bad position if it went south because I`d expect it to last 10 years or so (ok maybe that`s a stretch but 5 years at least)...also to be honest, for the price I am not sure why they are not warrantied longer.


    Brandt K.

  5. #5
    512detail's Avatar
    Join Date
    May 2013
    Location
    Kyle, Tx
    Posts
    8,069
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    Quote Originally Posted by Ronkh View Post
    If you need, I can lend you my long neck (still haven`t used it)
    can you even find that box?


    Brandt K.
    Likes Ronkh liked this post

  6. #6

    Join Date
    Jun 2009
    Location
    LI
    Posts
    3,917
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    I own a long neck I can loan you.

    I think I have 10 minutes on the sucker.

    Used it to clean up some MM on a vented engine cover.

    Worked like a champ, used battery only.
    Likes Ronkh, GearHead_1 liked this post

  7. #7
    Administrator GearHead_1's Avatar
    Join Date
    Jul 2003
    Location
    Utah
    Posts
    9,834
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    Quote Originally Posted by Ronkh View Post
    If you need, I can lend you my long neck (still haven`t used it)
    Well, if Justin doesn`t jump on it I`ll be happy to have you lend it to me. Now, about that return date...
    A society willing to trade liberty for temporary security deserves neither and will lose both
    ΜΟΛΩΝ ΛΑΒΕ
    Likes Ronkh, tropicsteve liked this post

  8. #8
    atgonzales's Avatar
    Join Date
    Apr 2015
    Posts
    362
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    Autopia is amazing, we had Budget giving product away and now we members wanting to loan tools, it does not get any better
    Anything in life worth doing is worth over doing, moderation is for cowards
    Likes 512detail, GearHead_1, Ronkh, Angus, mikejames and 3 others liked this post

  9. #9

    Join Date
    Feb 2014
    Location
    Rochester Ma
    Posts
    1,204
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    Thanks everyone who has offered to give me a loaner to use. Jeff JSFM35X I will be reaching out to you.

    Thanks bud.
    IGL Authorized Coating/Kenzo Installer

    Final Inspection Auto detailing- https://www.facebook.com/FinalInspection?_rdr=p
    Likes Ronkh, nickclark08 liked this post

  10. #10

    Join Date
    Feb 2014
    Location
    Rochester Ma
    Posts
    1,204
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    Thanks to Jeff for sending his out tomorrow overnight. Really appreciated.

    Here`s a video of mine acting up. Thumb was on the whole time. Speed 4 I think.

    https://youtu.be/0yHMUjEZkfg
    IGL Authorized Coating/Kenzo Installer

    Final Inspection Auto detailing- https://www.facebook.com/FinalInspection?_rdr=p
    Likes GearHead_1 liked this post

  11. #11
    512detail's Avatar
    Join Date
    May 2013
    Location
    Kyle, Tx
    Posts
    8,069
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    thanks for sharing that vid

    I can tell you mine (long neck) does the exact same thing from time to time

    But I just let off and press again and it works

    Additionally I`ve noticed a couple just weird quirks with charging a dead battery. Multiple times recently have noticed it tries to tell me my battery has charged within like 5 minutes and I`ll put it back in the Nano and it`s orange but not red and it`s supposed to be bright green of course on the light. Then I`ll fiddle with the charging dock station and put the orange battery back on and it will charge back up i.e. show red as if charging on dock bay


    Brandt K.

  12. #12
    Administrator GearHead_1's Avatar
    Join Date
    Jul 2003
    Location
    Utah
    Posts
    9,834
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    Quote Originally Posted by Justins00ss View Post
    Thanks to Jeff for sending his out tomorrow overnight. Really appreciated.

    Here`s a video of mine acting up. Thumb was on the whole time. Speed 4 I think.

    https://youtu.be/0yHMUjEZkfg
    Yeah, that`s not good.
    A society willing to trade liberty for temporary security deserves neither and will lose both
    ΜΟΛΩΝ ΛΑΒΕ

  13. #13

    Join Date
    Feb 2014
    Location
    Rochester Ma
    Posts
    1,204
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    Quote Originally Posted by 512detail View Post
    thanks for sharing that vid

    I can tell you mine (long neck) does the exact same thing from time to time

    But I just let off and press again and it works

    Additionally I`ve noticed a couple just weird quirks with charging a dead battery. Multiple times recently have noticed it tries to tell me my battery has charged within like 5 minutes and I`ll put it back in the Nano and it`s orange but not red and it`s supposed to be bright green of course on the light. Then I`ll fiddle with the charging dock station and put the orange battery back on and it will charge back up i.e. show red as if charging on dock bay
    Quote Originally Posted by GearHead_1 View Post
    Yeah, that`s not good.
    Yeah for the price this thing should work without issues. I know once in a great while my thumb will slip off the side of the switch and it will turn off but that`s definitely not the case here. Probably going back with a PE8 again after this is over.
    IGL Authorized Coating/Kenzo Installer

    Final Inspection Auto detailing- https://www.facebook.com/FinalInspection?_rdr=p

  14. #14
    RaydiantDetail's Avatar
    Join Date
    Mar 2016
    Location
    Atlanta
    Posts
    535
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    Sorry for your bad experience.
    I bought my long neck around the time they came out as well. I remember mine not working and had to send it back to Rupes and they sent me a replacement pretty quickly. Since then I use it for most of my details and have no had an issue.
    Glad a member was able to send you one! That is super awesome and this is seriously a great place!
    I hope you get your issue sorted out with Rupes they should take care of you!

  15. #15

    Join Date
    Feb 2014
    Location
    Rochester Ma
    Posts
    1,204
    Post Thanks / Like

    Re: Very Displeased with Ibrid

    Just a quick update. Spoke with Dylan Von Kleist and we got the warranty claim started and we will see what happens. There definitely going to cover it. Weather it gets fixed or he authorizes a replacement. He definitely understood my frustration and although not a common issue did say he has seen a handful of them with it.

    On another note I did order a new Flex PE8 to use a another option.
    IGL Authorized Coating/Kenzo Installer

    Final Inspection Auto detailing- https://www.facebook.com/FinalInspection?_rdr=p
    Likes Ronkh, Angus, 512detail, The Driver liked this post

 

 
Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Even cheaper iBrid Nano alternative
    By WaxAddict in forum Everything Else
    Replies: 8
    Last Post: 02-21-2017, 10:33 PM
  2. LHR75E vs Ibrid nano?
    By The Driver in forum Rupes Polishers
    Replies: 11
    Last Post: 06-18-2016, 05:47 AM
  3. Rupes iBrid Pre-Order Price
    By XxBoostinxX in forum Car Detailing Product Discussion
    Replies: 19
    Last Post: 02-19-2016, 07:58 PM
  4. iBrid Spy Shot????
    By Angus in forum Rupes Polishers
    Replies: 12
    Last Post: 11-02-2015, 05:09 PM
  5. LC Cutting Pad... I`m very displeased.
    By MongooseGA in forum Car Detailing Product Discussion
    Replies: 25
    Last Post: 11-03-2004, 08:34 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •