Results 1 to 4 of 4
  1. #1
    ShaneB's Avatar
    Join Date
    Jan 2013
    Location
    Northville, MI
    Posts
    1,249
    Post Thanks / Like

    Something changed with HD Speed?

    Got some new bottles (last one purchased was maybe middle of last summer) and I`ve had a couple cars recently that it`s not playing nice on. I`m not seeing really any haze or marring, just product that is impossible to wipe off. Spray and wipe with a little elbow grease seems to do the trick but thats almost counter productive at that point. I`ve never had an issue before, even in direct sunlight on black. The last 2 cars I did tho have had this problem though.

    Was something changed or should I be looking at my pads/technique? Besides the new bottle, the only change this year to last is I`m now using buff n shine uro tec pads instead of their regular flat pads

  2. #2

    Join Date
    Apr 2016
    Posts
    200
    Post Thanks / Like

    Re: Something changed with HD Speed?

    Yah, change to the flat pads. You have nothing to lose except a little product

    Sent from my SM-T550 using Tapatalk

  3. #3
    Autopia Specialist Vega@RaysWayDetailing's Avatar
    Join Date
    Jan 2014
    Posts
    4,692
    Post Thanks / Like

    Re: Something changed with HD Speed?

    Aw I really hope not. I`m just about finished with my last 32 oz bottle in the original packaging (no purple tip) and it has always worked amazing. I used it on a black Mustang this morning and wipe off was effortless. Maybe 3D 505 Correction Glaze is the better version? I remember thinking that the AAT formulas were changed so this wouldn`t be the first time.



    Instagram: www.instagram.com/rayswaydetailing
    Facebook: www.facebook.com/RaysWayDetailing

  4. #4
    LashingStanley's Avatar
    Join Date
    Oct 2015
    Posts
    53
    Post Thanks / Like

    Re: Something changed with HD Speed?

    Quote Originally Posted by Vega@RaysWayDetailing View Post
    Aw I really hope not. I`m just about finished with my last 32 oz bottle in the original packaging (no purple tip) and it has always worked amazing. I used it on a black Mustang this morning and wipe off was effortless. Maybe 3D 505 Correction Glaze is the better version? I remember thinking that the AAT formulas were changed so this wouldn`t be the first time.



    It`s taken me almost a year to finish my 32oz. bottles of 3D 501 & 502. I wasn`t going to reorder because the compound and polish are so runny and I`m lucky to get through 1 pass on low speed before they have dried onto the panel. Removal of AAT 501 is definitely more difficult than HD cut+ and even though I`m told 502 has cut similar to HD adapt, it only stays lubricated enough for me to do 1 pass at 600rpm on the rotary.

    HD Polish+ has always been my go-to polish that works on 90% of paints and I personally have used an entire gallon since August of 2016 (which is a ton especially since so little is required and I don`t prime my pads)

    Are the AAT 502 finishing polish and AAT 501 compound suppose to be more runny than Cut+ and Polish+? I recently had a bottle of cut+ lose it`s consistency and turn runny. I wonder if that is what the problem is with my old bottles of 501 and 502?

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Changed my look a little....
    By Sizzle Chest in forum Hot Tub
    Replies: 27
    Last Post: 05-18-2017, 09:15 PM
  2. Has NXT changed?
    By Wildcat99 in forum Car Detailing
    Replies: 3
    Last Post: 04-27-2006, 07:29 AM
  3. So I changed my oil...
    By Corey Bit Spank in forum Car & Driver
    Replies: 33
    Last Post: 09-13-2004, 04:48 AM
  4. Has 3M`s IHG Formula Changed?
    By jmsc in forum Car Detailing Product Discussion
    Replies: 2
    Last Post: 08-24-2004, 08:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •